Installation problem Neuron

neuronakash
Posts: 8
Joined: Mon Sep 10, 2018 10:32 am

Installation problem Neuron

Post by neuronakash » Mon Sep 10, 2018 4:12 pm

Hello,

I have downloaded neuron, and have the associated modules etc. but I cant seem to get it to open up when I launch nrngui. I have macOS Mojave Version 10.14 Beta.

-e
/Applications/NEURON-7.6/nrn/x86_64/bin/set_nrnpyenv.sh: line 33: 2156 Abort trap: 6 nrniv -c 'quit()' >&/dev/null
/Applications/NEURON-7.6/nrn/x86_64/bin/set_nrnpyenv.sh: line 33: 2174 Abort trap: 6 nrniv -c 'quit()' >&/dev/null
Attempt to fix nrniv failure using: eval "`mk_nrnpyenv.sh`" failed.
dyld: Symbol not found: _rl_event_hook
Referenced from: /Applications/NEURON-7.6/nrn/x86_64/lib/liboc.0.dylib
Expected in: flat namespace
in /Applications/NEURON-7.6/nrn/x86_64/lib/liboc.0.dylib
./nrngui.sh: line 27: 2175 Abort trap: 6 ${NRNGUI}
nrngui exit status was 134
Press return key to exit

hines
Site Admin
Posts: 1526
Joined: Wed May 18, 2005 3:32 pm

Re: Installation problem Neuron

Post by hines » Mon Sep 10, 2018 6:10 pm

Did you build from sources or use the pkg file distribution. If the latter, have you intalled the software from xquartz.org and the command
line tools. If the latter what configure line did you use. What python do you have installed. Does the following work?
Start a terminal window and in the terminal window type
/Applications/NEURON-7.6/nrn/x86_64/bin/nrniv -nopython

Sounds like I may have to install another virtualbox guest on my mac 10.13

neuronakash
Posts: 8
Joined: Mon Sep 10, 2018 10:32 am

Re: Installation problem Neuron

Post by neuronakash » Mon Sep 10, 2018 9:09 pm

Im uninstalling it and downloading it again. Also, I am downloading command line tools but it is still not working. I have python 3.7 downloaded.

hines
Site Admin
Posts: 1526
Joined: Wed May 18, 2005 3:32 pm

Re: Installation problem Neuron

Post by hines » Mon Sep 10, 2018 9:39 pm

I tried to install the mojave beta on a virtual box clone of high sierra. Gets what seems to be close to success but will not boot. Hangs at the
boot message
/dev/disk0s2 on / (hfs, local, journaled)

neuronakash
Posts: 8
Joined: Mon Sep 10, 2018 10:32 am

Re: Installation problem Neuron

Post by neuronakash » Tue Sep 11, 2018 6:18 pm

Ok, so are some steps i can take to fix the installation process.

hines
Site Admin
Posts: 1526
Joined: Wed May 18, 2005 3:32 pm

Re: Installation problem Neuron

Post by hines » Tue Sep 11, 2018 8:34 pm

I'd like to know the result of the terminal experiment I mentioned earlier. That will generate several further questions.

neuronakash
Posts: 8
Joined: Mon Sep 10, 2018 10:32 am

Re: Installation problem Neuron

Post by neuronakash » Tue Sep 11, 2018 10:36 pm

This is what I got when I entered that line in terminal.

dyld: Symbol not found: _rl_event_hook
Referenced from: /Applications/NEURON-7.6/nrn/x86_64/lib/liboc.0.dylib
Expected in: flat namespace
in /Applications/NEURON-7.6/nrn/x86_64/lib/liboc.0.dylib
Abort trap: 6
Akashs-MacBook-Air:~ akashchandra$

hines
Site Admin
Posts: 1526
Joined: Wed May 18, 2005 3:32 pm

Re: Installation problem Neuron

Post by hines » Wed Sep 12, 2018 7:10 am

one last diagnostic test using a terminal window. What is the output of
otool -L /Applications/NEURON-7.6/nrn/x86_64/bin/nrniv
The executable expects to get those variables from /usr/lib/libedit.3.dylib
Also what is the result of
ls -l /usr/lib/libedit*
ls -l /usr/lib/libreadline*

neuronakash
Posts: 8
Joined: Mon Sep 10, 2018 10:32 am

Re: Installation problem Neuron

Post by neuronakash » Wed Sep 12, 2018 9:50 am

The output for otool -L /Applications/NEURON-7.6/nrn/x86_64/bin/nrniv is,
/Applications/NEURON-7.6/nrn/x86_64/bin/nrniv:
/Applications/NEURON-7.6/nrn/x86_64/lib/libnrnoc.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/Applications/NEURON-7.6/nrn/x86_64/lib/libnrniv.0.dylib (compatibility version 1.0.0, current version 1.0.0)

and for the ls -l /usr/lib/libedit* command it is

lrwxr-xr-x 1 root wheel 15 Aug 20 20:35 /usr/lib/libedit.2.dylib -> libedit.3.dylib
lrwxr-xr-x 1 root wheel 15 Aug 20 20:35 /usr/lib/libedit.3.0.dylib -> libedit.3.dylib
-rwxr-xr-x 1 root wheel 308224 Aug 17 06:01 /usr/lib/libedit.3.dylib
lrwxr-xr-x 1 root wheel 15 Aug 20 20:35 /usr/lib/libedit.dylib -> libedit.3.dylib

ls -l /usr/lib/libreadline* output :

lrwxr-xr-x 1 root wheel 15 Aug 20 20:35 /usr/lib/libreadline.dylib -> libedit.3.dylib

hines
Site Admin
Posts: 1526
Joined: Wed May 18, 2005 3:32 pm

Re: Installation problem Neuron

Post by hines » Wed Sep 12, 2018 3:07 pm

The otool output for nrniv is seriously perplexing. Mine is much lengthier with...

Code: Select all

Michaels-MacBook-Pro:~ michaelhines$ otool -L /Applications/NEURON-7.6/nrn/x86_64/bin/nrniv
/Applications/NEURON-7.6/nrn/x86_64/bin/nrniv:
	/Applications/NEURON-7.6/nrn/x86_64/lib/libnrnoc.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/Applications/NEURON-7.6/nrn/x86_64/lib/libnrniv.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/Applications/NEURON-7.6/nrn/x86_64/lib/libivoc.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/Applications/NEURON-7.6/nrn/x86_64/lib/liboc.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/usr/X11/lib/libX11.6.dylib (compatibility version 10.0.0, current version 10.0.0)
	/Applications/NEURON-7.6/nrn/x86_64/lib/libneuron_gnu.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/Applications/NEURON-7.6/nrn/x86_64/lib/libscopmath.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/Applications/NEURON-7.6/nrn/x86_64/lib/libsparse13.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/Applications/NEURON-7.6/nrn/x86_64/lib/libsundials.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/Applications/NEURON-7.6/nrn/x86_64/lib/libmemacs.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/Applications/NEURON-7.6/nrn/x86_64/lib/libmeschach.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/Applications/NEURON-7.6/iv/x86_64/lib/libIVhines.3.dylib (compatibility version 4.0.0, current version 4.3.0)
	/usr/lib/libedit.3.dylib (compatibility version 2.0.0, current version 3.0.0)
	/usr/lib/libncurses.5.4.dylib (compatibility version 5.4.0, current version 5.4.0)
	/usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 400.9.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1252.50.4)
and you can see I'm getting libedit to resolve all the readline variables . ie.
lrwxr-xr-x 1 root wheel 15 Mar 28 05:53 /usr/lib/libreadline.dylib -> libedit.3.dylib

It seems like your problem is that dynamic libraries that exist in their normal places are not being requested, or loaded. Or perhaps I'm barking up
the wrong tree. I don't have any ideas
off hand as to why that would occur or how to deal with it. I will need to install Mojave, and experiment with that.

neuronakash
Posts: 8
Joined: Mon Sep 10, 2018 10:32 am

Re: Installation problem Neuron

Post by neuronakash » Fri Sep 14, 2018 9:39 am

ok thank you. Were you able to play around with it.

Thanks

hines
Site Admin
Posts: 1526
Joined: Wed May 18, 2005 3:32 pm

Re: Installation problem Neuron

Post by hines » Fri Sep 14, 2018 11:18 am

I've been unable to successfully install mojave as a virtual box guest. It will be away for two weeks and can get back to the problem at that time.

was2be
Posts: 4
Joined: Wed Sep 26, 2018 3:34 pm

Re: Installation problem Neuron

Post by was2be » Fri Sep 28, 2018 1:02 pm

I have the same problem after installing last week's official release of 10.14 Mojave.

With the latest Mojave command line tools and X11 installed, and a fresh install of NEURON 7.6, attempting to open nrngui leads to the following:

Last login: Wed Sep 26 21:14:42 on ttys001
Axon:~ testuser$ cd ; clear; cp .nrn_as2sh /tmp/nrn_as2sh$$; sh /tmp/nrn_as2sh$$;rm -f /tmp/nrn_as2sh$$ ; exit
-e
/Applications/NEURON-7.6/nrn/x86_64/bin/set_nrnpyenv.sh: line 33: 12373 Abort trap: 6 nrniv -c 'quit()' >&/dev/null
/Applications/NEURON-7.6/nrn/x86_64/bin/set_nrnpyenv.sh: line 33: 12383 Abort trap: 6 nrniv -c 'quit()' >&/dev/null
Attempt to fix nrniv failure using: eval "`mk_nrnpyenv.sh`" failed.
dyld: Symbol not found: _rl_event_hook
Referenced from: /Applications/NEURON-7.6/nrn/x86_64/lib/liboc.0.dylib
Expected in: flat namespace
in /Applications/NEURON-7.6/nrn/x86_64/lib/liboc.0.dylib
./nrngui.sh: line 27: 12384 Abort trap: 6 ${NRNGUI}
nrngui exit status was 134

The output from entering "otool -L /Applications/NEURON-7.6/nrn/x86_64/bin/nrniv" is:
/Applications/NEURON-7.6/nrn/x86_64/bin/nrniv:
/Applications/NEURON-7.6/nrn/x86_64/lib/libnrnoc.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/Applications/NEURON-7.6/nrn/x86_64/lib/libnrniv.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/Applications/NEURON-7.6/nrn/x86_64/lib/libivoc.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/Applications/NEURON-7.6/nrn/x86_64/lib/liboc.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/usr/X11/lib/libX11.6.dylib (compatibility version 10.0.0, current version 10.0.0)
/Applications/NEURON-7.6/nrn/x86_64/lib/libneuron_gnu.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/Applications/NEURON-7.6/nrn/x86_64/lib/libscopmath.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/Applications/NEURON-7.6/nrn/x86_64/lib/libsparse13.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/Applications/NEURON-7.6/nrn/x86_64/lib/libsundials.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/Applications/NEURON-7.6/nrn/x86_64/lib/libmemacs.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/Applications/NEURON-7.6/nrn/x86_64/lib/libmeschach.0.dylib (compatibility version 1.0.0, current version 1.0.0)
/Applications/NEURON-7.6/iv/x86_64/lib/libIVhines.3.dylib (compatibility version 4.0.0, current version 4.3.0)
/usr/lib/libedit.3.dylib (compatibility version 2.0.0, current version 3.0.0)
/usr/lib/libncurses.5.4.dylib (compatibility version 5.4.0, current version 5.4.0)
/usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 400.9.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1252.50.4)

The output of "ls -l /usr/lib/libedit*" is:

lrwxr-xr-x 1 root wheel 15 Sep 24 15:03 /usr/lib/libedit.2.dylib -> libedit.3.dylib
lrwxr-xr-x 1 root wheel 15 Sep 24 15:03 /usr/lib/libedit.3.0.dylib -> libedit.3.dylib
-rwxr-xr-x 1 root wheel 308224 Sep 21 00:17 /usr/lib/libedit.3.dylib
lrwxr-xr-x 1 root wheel 15 Sep 24 15:03 /usr/lib/libedit.dylib -> libedit.3.dylib


The output of "ls -l /usr/lib/libreadline*" is

lrwxr-xr-x 1 root wheel 15 Sep 24 15:03 /usr/lib/libreadline.dylib -> libedit.3.dylib

hines
Site Admin
Posts: 1526
Joined: Wed May 18, 2005 3:32 pm

Re: Installation problem Neuron

Post by hines » Sat Sep 29, 2018 2:39 am

If installing from sources, use the configure option --with-readline=no
Also a library I used for the icon launch mechanism has been deprecated out of existence. That can be temporarily worked around by
modifying nrn/src/mac/Makefile.am to comment out a single line. ie.

Code: Select all


diff --git a/src/mac/Makefile.am b/src/mac/Makefile.am
index a612653..241f45a 100755
--- a/src/mac/Makefile.am
+++ b/src/mac/Makefile.am
@@ -23,7 +23,7 @@ if UniversalMacBinary
        $(CC) -arch i386 -o aouti386 -Dcpu="\"$(host_cpu)\"" -I. $(srcdir)/launch.c $(srcdir)/mac2uxarg.c -framework Carbon
        lipo aouti386 aoutppc -create -output a.out
 else
-       gcc -g -arch i386 -Dncpu="\"$(host_cpu)\"" -I. $(srcdir)/launch.c $(srcdir)/mac2uxarg.c -framework Carbon
+#      gcc -g -arch i386 -Dncpu="\"$(host_cpu)\"" -I. $(srcdir)/launch.c $(srcdir)/mac2uxarg.c -framework Carbon
 
 endif
        carbon=$(carbon) sh $(srcdir)/launch_inst.sh "$(host_cpu)" "$(DESTDIR)$(prefix)" "$(srcdir)"
If you install from a package file, let me know and I can upload to the alpha folder.

was2be
Posts: 4
Joined: Wed Sep 26, 2018 3:34 pm

Re: Installation problem Neuron

Post by was2be » Sat Sep 29, 2018 10:55 pm

I'm installing from the latest package installer. Thanks.

Post Reply