cvode.use_daspk error

General issues of interest both for network and
individual cell parallelization.

Moderator: hines

Post Reply
Krishna Chaitanya
Posts: 70
Joined: Wed Jan 18, 2012 12:25 am
Location: University of Pavia

cvode.use_daspk error

Post by Krishna Chaitanya » Tue Sep 10, 2013 10:18 am

Hi,

I have tried parallelization of different types of cells by putting them in one for loop and checking with the local variable i whether it has reached the cell count limit. And based upon that it is assigned gids.

Now when I use the below lines:
cvode=new CVode()
cvode.active(1)
cvode.use_daspk(1)
cvode.condition_order(2)

It gives me this error:
2 /home/krishna/nrn-7.3_installed/x86_64/bin/nrniv: spFactor error: Singular
2 in test_mosinit.hoc near line 102
2 cvode.use_daspk(1)
^
2 CVode[1].use_daspk(1)
application called MPI_Abort(MPI_COMM_WORLD, -1) - process 2

However, when I use only one cell type, it doesn't give any problem. The problem seems to arise when two different cell types are created within for loop.

Kindly let me know how I can solve this problem.

Thank you.

ted
Site Admin
Posts: 5672
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: cvode.use_daspk error

Post by ted » Wed Sep 11, 2013 10:06 am

What happens if you replace
cvode.active(1)
with
cvode_active(1)
?

Krishna Chaitanya
Posts: 70
Joined: Wed Jan 18, 2012 12:25 am
Location: University of Pavia

Re: cvode.use_daspk error

Post by Krishna Chaitanya » Wed Sep 11, 2013 10:26 pm

Hi,

The problem now seems to be with cvode.use_daspk(1) after I changed cvode.active(1) to cvode_active(1).

1 /home/krishna/nrn-7.3_installed/x86_64/bin/nrniv: spFactor error: Singular
1 in test_mosinit.hoc near line 102
1 cvode.use_daspk(1)
^
1 CVode[1].use_daspk(1)
application called MPI_Abort(MPI_COMM_WORLD, -1) - process 1

How do I resolve this? Kindly let me know.

Thank you.

hines
Site Admin
Posts: 1584
Joined: Wed May 18, 2005 3:32 pm

Re: cvode.use_daspk error

Post by hines » Fri Sep 13, 2013 11:24 am

I don't know which secton of code is to blame given the combination of your (unknown to me) network model, the DAE solver, and condition order 2.
Could you please send me the hoc,mod,ses,py, etc, files in a zip file so I can observe the error. Send to michael dot hines at yale dot edu .
I'm guessing that your model does not require the DAE solver (only needed if extracellular or LinearMechanism is being used) so I'd like to know also if it works without the cvode.use_daspk.

Post Reply