Running neuroConstruct Model

The basics of how to develop, test, and use models.
Post Reply
DKPOWA
Posts: 2
Joined: Tue Jun 03, 2014 11:09 am

Running neuroConstruct Model

Post by DKPOWA »

Hi everyone,

My name is Maxi, I'm a biologist, and I'm doing my PhD on neuroinformatics, modelling neural networks. I'm using Ubuntu 13.10 64-bit, I have installed both neuroConstruct 1.6.0 and Neuron 7.3.

When I run neurondemo I get:
---------------------------------------------------------------------------------------------------------
NEURON -- VERSION 7.3 ansi (1078:2b0c984183df) 2014-04-04
Duke, Yale, and the BlueBrain Project -- Copyright 1984-2014
See http://www.neuron.yale.edu/neuron/credits

loading membrane mechanisms from /usr/local/nrn/share/nrn/demo/release/x86_64/.libs/libnrnmech.so
Additional mechanisms from files
cabpump.mod cachan1.mod camchan.mod capump.mod invlfire.mod khhchan.mod mcna.mod nacaex.mod nachan.mod release.mod
nrniv: unable to open font "*helvetica-medium-r-normal*--14*", using "fixed"
oc>
---------------------------------------------------------------------------------------------------------

Ending with this self introduction, my problem:

Whenever I try to create a hoc simulation in neuroConstruct to run it on Neuron, I get the following error:
---------------------------------------------------------------------------------------------------------
Problem with the compilation. File doesn't exist: home/"user"/"location of ncx file"/generatedNEURON/x86_64/libnrnmech.la
Please note that Neuron check's every *.mod file in this file's home directory
(home/user/location of ncx file/generatedNEURON)
---------------------------------------------------------------------------------------------------------

I must admit I'm both new on Ubuntu and neuroC/NEURON, but I think I followed installing and operating instructions well enough, so I really don't understand what is wrong. If this is a simple/stupid mistake, I deeply apologize but I will be very grateful for it's solution.

Kinds regards,
Maxi
ted
Site Admin
Posts: 5810
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: Running neuroConstruct Model

Post by ted »

DKPOWA wrote:nrniv: unable to open font "*helvetica-medium-r-normal*--14*", using "fixed"
This one is easy--search the Forum for helvetica, and 10 matches are found including this one
viewtopic.php?f=6&t=1772&p=9596#p9596

The other one I have not seen, but then I don't know anything about neuroConstruct--you might ask Padraig Gleeson, then post the answer to this thread where it might benefit others in the future. But before you ask him, make sure you can compile mod files. Download the zip file for this model
https://senselab.med.yale.edu/modeldb/S ... del=125745
then unzip it, cd into the expanded directory, then execute
nrnivmodl
nrngui mosinit.hoc
and click on the Movie Run tool's "Init & Run" button. Each of these steps should succeed.
DKPOWA
Posts: 2
Joined: Tue Jun 03, 2014 11:09 am

Re: Running neuroConstruct Model

Post by DKPOWA »

ted wrote:But before you ask him, make sure you can compile mod files. Download the zip file for this model
https://senselab.med.yale.edu/modeldb/S ... del=125745
then unzip it, cd into the expanded directory, then execute
nrnivmodl
nrngui mosinit.hoc
and click on the Movie Run tool's "Init & Run" button. Each of these steps should succeed.
I did it, when I run the nrninvmodl command I got this error (there are more lines before this one, but they seem standard code):
--------------------------------------------------------------------------------------
/usr/bin/ld: cannot find -lncurses
collect2: error: ld returned 1 exit status
make: *** [libnrnmech.la] Error 1
--------------------------------------------------------------------------------------

when I run nrngui mosinit.hoc, Neuron runs, it opens the GUI with the graphs windows, but when I hit "Init & Run", on the Run Control the counter starts, but there is no visible simulation evidence.

I hope this is enough info for you to asess what's wrong.
ted
Site Admin
Posts: 5810
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: Running neuroConstruct Model

Post by ted »

DKPOWA wrote:when I run the nrninvmodl command I got this error
. . .
/usr/bin/ld: cannot find -lncurses
collect2: error: ld returned 1 exit status
make: *** [libnrnmech.la] Error 1
Well, there's the cause of your problem--you can't compile mod files. Ubuntu is very nice in many regards, but for reasons known only to its developers, users frequently end up with systems that can't deal with source code that uses ncurses. This is totally fixable, however. Use your Linux distribution's package manager to discover and install the package(s) that it needs for development or compilation of programs that use ncurses. Then try the steps that I recommended, and if everything works with that model, try neuroConstruct again.
Post Reply