Vector play error

Anything that doesn't fit elsewhere.
Post Reply
wvangeit
Posts: 21
Joined: Wed Jun 11, 2008 2:14 am

Vector play error

Post by wvangeit » Mon Aug 17, 2009 12:38 am

Hi,
Does anybody have any idea why the following code is not working anymore in Neuron 7 (Revision 2227) ?

Code: Select all

create soma

objref vclamp1, v1

v1 = new Vector(1000000)

soma {
    vclamp1 = new SEClamp(.5)
    v1.play(&vclamp1.amp1,0.02)
}

tstop = 1000

run()
I get the error:

Code: Select all

NEURON -- VERSION 7.0.0 (2227) 2008-09-22 (2227M)
Duke, Yale, and the BlueBrain Project -- Copyright 1984-2008
See http://www.neuron.yale.edu/credits.html

nrniv: ../nrncvode/netcvode.cpp:3208: virtual void PlayRecordEvent::deliver(double, NetCvode*, NrnThread*): Assertion `nt == plr_->cvode_->nth_' failed.
Aborted
It works perferctly in older versions of Neuron (prior to 7.0) that I've tried.

Thx,

Werner Van Geit
Last edited by wvangeit on Mon Aug 17, 2009 2:06 am, edited 1 time in total.

wvangeit
Posts: 21
Joined: Wed Jun 11, 2008 2:14 am

Re: Vector play error

Post by wvangeit » Mon Aug 17, 2009 12:55 am

Small addition, it seems to work in Neuron 7 that is compiled from the tarball on the website, but I'm using the latest repository release, downloaded with subversion.

Werner

wvangeit
Posts: 21
Joined: Wed Jun 11, 2008 2:14 am

Re: Vector play error

Post by wvangeit » Mon Aug 17, 2009 2:37 am

Okay, have discovered the problem, apparently the subversion archive doesn't contain the latest release, have used the Mercurial repository now. This solves the problem.

Werner

ted
Site Admin
Posts: 5683
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: Vector play error

Post by ted » Mon Aug 17, 2009 1:22 pm

Was there a page on the WWW site that directed you to the subversion repository? If so, let me know and I'll change it to point people to the mercurial repository.

wvangeit
Posts: 21
Joined: Wed Jun 11, 2008 2:14 am

Re: Vector play error

Post by wvangeit » Mon Aug 17, 2009 7:53 pm

Hi,
No, not at the moment I think, but when I started using that subversion archive more than a year ago, I think there was. I was just doing 'svn update' to get the new release, didn't realize that you stopped using that archive.

Werner

ted
Site Admin
Posts: 5683
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: Vector play error

Post by ted » Mon Aug 17, 2009 8:10 pm

That's an easy mistake to make. We should probably take that repository off a public server.

Post Reply