Choice of Python2.7 or 3.xx on install?

Post Reply
wwlytton
Posts: 64
Joined: Wed May 18, 2005 10:37 pm

Choice of Python2.7 or 3.xx on install?

Post by wwlytton » Tue Dec 05, 2017 4:32 am

I'm guessing that Anaconda gives you both 2 and 3 and that when NEURON detects that you have 3 installed it assumes that you want to use the more modern version??

I have no personal experience on this; A student reports:

having trouble getting my Python 2.7 Anaconda env working
...
py2.7 problem turned out nothing to do with macos. for whatever reason, Neuron install added following to bash:‘code’

export PYTHONHOME=“/anaconda3” #added by NEURON installer

Post Reply