parallel simulation hang on permanently at some loops

General issues of interest both for network and
individual cell parallelization.

Moderator: hines

Post Reply
ylzang
Posts: 27
Joined: Sun Mar 08, 2015 3:38 am

parallel simulation hang on permanently at some loops

Post by ylzang » Thu Oct 31, 2019 11:23 am

The job is pretty simple. I run many loops and just parallelize them by ParallelContext. The program runs well on my Macbook Pro by NEURON 7.5, cluster by coreNEURON, and on Comet by NEURON 7.5. I recently installed NEURON 7.7 on Manjaro linux system and run the same simulation. However, something confusing occurred. The simulation hang on some loops permanently and never proceeds or stops... No errors. More weird, the loop where the work hangs on changes every time when I try to re-implement the simulation. Anybody has an idea what may be the reason.
Best,
Yunliang

hines
Site Admin
Posts: 1580
Joined: Wed May 18, 2005 3:32 pm

Re: parallel simulation hang on permanently at some loops

Post by hines » Fri Nov 01, 2019 9:29 am

You did not mention whether the 7.7 version hangs on your Macbook pro and on comet. Or if NEURON 7.5 has no problem on Manjaro linux.
There have been a lot of mpi changes since 7.5. If it does not take too long to run an example, you can send me a zip file with sufficient
code to exhibit the problem and I can try it on my ubuntu desktop (8 cores). What is your mpi version? I'm a little confused by the mention of
coreNEURON as I generally don't consider that as supporting loop parallelization with ParallelContext but only parallelization of networks.

Post Reply