wrong initialization or wrong mechanisms?

Anything that doesn't fit elsewhere.
Post Reply
menica
Posts: 47
Joined: Wed Sep 02, 2015 11:02 am

wrong initialization or wrong mechanisms?

Post by menica » Tue Jul 05, 2016 4:27 am

dear Ted,
I am working with 2 cell connected by an Expsyn. The first cell is 1 comp. (soma), the second cell is 2 comp (soma+dend).
I am using the na and k channels mechanisms by Migliore https://senselab.med.yale.edu/ModelDB/S ... mod#tabs-2 that should work fine at 35-37 degC.
I am using this intialization procedure:

Code: Select all

proc init() {
finitialize(v_init)
forall for (x,0) concentration_init()
forall for (x,0){
  if (ismembrane("NaKpump")) {
       ic_bias(x) = -(ina + ik + i_leakad +ink_NaKpump )
   } else {
    ic_bias(x) = -(ina+ik+i_leakad)
    }
}
if (cvode.active()) {
    cvode.re_init()
  } else {
    fcurrent()
  }
  frecord_init()
}
If i uninsert Nakpump the compartments of the model at rest have all the same v_init, but when Nakpump is inserted in the dend of the second cell on;ly the soma of the first cell is correctli initalized, the spoma and dend of the second cell doesn't stabilize at the same v_init.

I had the same problem also using these simple models for na and k channel:

Code: Select all

:NMODL K+ current: 

NEURON{ 
SUFFIX kad 
USEION k READ ek WRITE ik 
RANGE gkbar, ik 
} 

UNITS{ 
(S)=(siemens) 
(mV)=(millivolt) 
(mA)=(milliamp) 
} 

PARAMETER{gkbar=0.036 (S/cm2)} 

ASSIGNED{ 
v (mV) 
ek (mV) : typically ~ -70 
ik (mA/cm2) 
} 

STATE{n} 

BREAKPOINT{ 
SOLVE states METHOD cnexp 
ik=gkbar*n^4*(v-ek) 
} 

INITIAL{ 
n=alpha(v)/(alpha(v)+beta(v)) 
} 

DERIVATIVE states{ 
n'=(1-n)*alpha(v)-n*beta(v) 
} 

FUNCTION alpha(Vm (mV)) (/ms){ 
UNITSOFF 
alpha=(0.01*((-70-Vm)+10))/(exp(((-70-Vm)+10)/10)-1) 
UNITSON 
} 

FUNCTION beta(Vm (mV)) (/ms){ 
UNITSOFF 
beta=0.125*exp((-70-Vm)/80) 
UNITSON 
} 

:cambia 70 con 65

Code: Select all

:NMODL for Na+ current: 

NEURON{ 
SUFFIX nad 
USEION na READ ena WRITE ina 
RANGE gnabar, ina 
} 

UNITS { 
(S) = (siemens) 
(mV) = (millivolt) 
(mA) = (milliamp) 
} 

PARAMETER{ gnabar=0.12 (S/cm2)} 

ASSIGNED{ 
v (mV) 
ena (mV) : typically ~ +55 
ina (mA/cm2) 
} 

STATE { m h} 

BREAKPOINT{ 
SOLVE states METHOD cnexp 
ina=gnabar*m^3*h*(v-ena) 
} 

INITIAL{ 
m=alpham(v)/(alpham(v)+betam(v)) 
h=alphah(v)/(alphah(v)+betah(v)) 
} 

DERIVATIVE states{ 

m'=alpham(v)*(1-m)-m*betam(v) 
h'=alphah(v)*(1-h)-betah(v)*h 
} 

FUNCTION alpham(Vm (mV)) (/ms){ 
UNITSOFF 

alpham=(0.1*(-70-Vm+25))/(exp((-70-Vm+25)/10)-1) 
UNITSON 
} 

FUNCTION betam(Vm (mV)) (/ms){ 
UNITSOFF 
betam=4*exp((-70-Vm)/18) 
UNITSON 
} 

FUNCTION alphah(Vm (mV)) (/ms){ 
UNITSOFF 
alphah=0.07*exp((-70-Vm)/20) 
UNITSON 
} 

FUNCTION betah(Vm (mV)) (/ms){ 
UNITSOFF 
betah=1/(exp((-70-Vm+30)/10)+1) 
UNITSON 
} 
This is the model of the pump:

Code: Select all

TITLE sodium potassium pump
:  from Lindblad et al Am J Physiol 1996 275:H1666

NEURON {
	SUFFIX NaKpump
	USEION k READ ki, ko WRITE ik
	USEION na READ nai, nao WRITE ina
	RANGE ik, ina , INaKmax, ink, Kmko, Kmnai, n, m
	GLOBAL dummy : prevent vectorization for use with CVODE
}

UNITS {
	(mA) = (milliamp)
	(mV) = (millivolt)
	
}

PARAMETER {
	INaKmax = 2.18660e-3       (mA/cm2) <0,1e6>
	Kmnai =    10          (mM)    <0,1e6>
	Kmko =      1.5         (mM)    <0,1e6>
    n=1.5
    m=1
}

ASSIGNED {
	celsius (degC)
	v (mV)
	ik (mA/cm2)
	ina (mA/cm2)
	ko (mM)
        ki (mM)
	nao (mM)
	nai (mM)
	ink (mA/cm2)
	dummy
}


BREAKPOINT { LOCAL q10, fnk
	
fnk = (v + 150)/(v + 200)

ink= INaKmax*fnk/((1 + (Kmnai/nai)^n)*(1 + (Kmko/ko)^m))
	ina = 3*ink
	ik = -2*ink
}
how could I initilaize all the comp of the model at the same v_init? I need to customize it for each com? or is something wrong in the mechanisms inserted?

Best
Menica

ted
Site Admin
Posts: 5057
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: wrong initialization or wrong mechanisms?

Post by ted » Tue Jul 05, 2016 9:33 pm

menica wrote:If i uninsert Nakpump the compartments of the model at rest have all the same v_init, but when Nakpump is inserted in the dend of the second cell on;ly the soma of the first cell is correctli initalized, the spoma and dend of the second cell doesn't stabilize at the same v_init.
Isn't that exactly what should happen in a model that has a mechanism that changes ena and ek? The only way to prevent that from happening is to adjust the active transport mechanism's parameters so that the Na and K fluxes it generates exactly cancel out the membrane currents generated by whatever Na and K ion channels are present when the cell is initialized to whatever you want to use for the initial membrane potential.

menica
Posts: 47
Joined: Wed Sep 02, 2015 11:02 am

Re: wrong initialization or wrong mechanisms?

Post by menica » Wed Jul 06, 2016 8:18 am

Dear Ted,
to adjust the active transport mechanism's parameters so that the Na and K fluxes it generates exactly cancel out the membrane currents generated by whatever Na and K ion channels are present when the cell is initialized
it means that the initialization procedure I wrote is not correct? I need to insert for each ionic species I am considering in the model (na , k) a constant non-specific current which neutralize the pump effect (let's say , Iconst_na=-(1/3)*ina and Iconst_k=(1/2)*ik)? or I should adjust the parameters of g_na and g_k in the compartments where the pump is inserted in order to compensate the effect of the pump?

ted
Site Admin
Posts: 5057
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: wrong initialization or wrong mechanisms?

Post by ted » Thu Jul 07, 2016 12:25 am

The fundamental problem isn't "wrong initialization" or "wrong mechanisms." It's "wrong model"--that is, wrong conceptual model. You're trying to use an electrogenic pump mechanism that has a 3:2 stoichiometry in a model cell that lacks all of the stuff found in real cells that allows such a pump to work without disrupting ionic equilibrium potentials and resting potential. You're at a serious decision point: do you stick with your electrogenic pump mechanism and its stoichiometry, in which case you need to add several important complexities to your model, or do you take the (much) easier path of using simple first order differential equations to approximate the _effects_ of active transport on Na and K concentrations, and forget about pump stoichiometry and electrogenicity? The choice is yours. I can help with the specific problem that you're having right now, but if you choose the harder path, sooner or later you're liable to run into other difficult details and will have to team up with some close collaborator (not me--I have enough other stuff to do) who can help you with them.

menica
Posts: 47
Joined: Wed Sep 02, 2015 11:02 am

Re: wrong initialization or wrong mechanisms?

Post by menica » Fri Jul 08, 2016 9:33 am

Dear Ted,
thanks for the answer.
You're trying to use an electrogenic pump mechanism that has a 3:2 stoichiometry in a model cell that lacks all of the stuff found in real cells that allows such a pump to work without disrupting ionic equilibrium potentials and resting potential.....do you stick with your electrogenic pump mechanism and its stoichiometry, in which case you need to add several important complexities to your model,
If I want to use the electrogenic pump mechanism in the correct way, are you suggesting to insert more mechanisms in the cell, like as others kind of potassium channels, which could resotore the ionic equilibrium potentials and resting state?

As first step I would choose
the (much) easier path of using simple first order differential equations to approximate the _effects_ of active transport on Na and K concentrations
but, the effect of the pump, in this case, would be simply modeled by inserting the hh mechanism? the pump as "battery" of the ciruit?

menica
Posts: 47
Joined: Wed Sep 02, 2015 11:02 am

Re: wrong initialization or wrong mechanisms?

Post by menica » Tue Jul 26, 2016 8:39 am

Hi, this is just a remind for my previous post :)

menica
Posts: 47
Joined: Wed Sep 02, 2015 11:02 am

Re: wrong initialization or wrong mechanisms?

Post by menica » Tue Apr 04, 2017 12:22 pm

Dear Ted,
could you please indicate me some examples (mod files) where the effect of the Na/K pump has been approximated with simple first order differential equations?

I realized that a complex model at the moment is not what I want. I guess that when you said that in order to use an electrogenic pump I need to add several important complexities to the model you refer that O need to insert other currents related to Na and K ionic concentrations.

Best
Menica

ted
Site Admin
Posts: 5057
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: wrong initialization or wrong mechanisms?

Post by ted » Tue Apr 04, 2017 1:24 pm

You might try this one by Canavier to start with:
https://senselab.med.yale.edu/ModelDB/s ... model=6763

Other than that, you might want to do an "advanced search" for models implemented with NEURON that include the keyword "pump".

menica
Posts: 47
Joined: Wed Sep 02, 2015 11:02 am

Re: wrong initialization or wrong mechanisms?

Post by menica » Wed Apr 05, 2017 5:45 am

Thanks!
but in the Canavier model the pump is still electrogenic with the 3:2 stoichiometric ratio?

ted
Site Admin
Posts: 5057
Joined: Wed May 18, 2005 4:50 pm
Location: Yale University School of Medicine
Contact:

Re: wrong initialization or wrong mechanisms?

Post by ted » Wed Apr 05, 2017 11:04 am

If the model that Canavier used isn't suitable, check out the other entries in ModelDB that were implemented in NEURON and included the keyword "pump". There were about 60 of them. Many are calcium pumps, but there are probably some Na and/or K pumps.

Post Reply