Search found 6 matches

by DavidSwygart
Tue Jan 08, 2019 3:02 pm
Forum: Getting started
Topic: Connecting a new section to your model within a process or function
Replies: 1
Views: 879

Connecting a new section to your model within a process or function

Hello, I am trying to add new sections to an existing model. I can create the new sections and successfully access the sections of the old model that I want to connect them to (using forsec), however, I get a syntax error when trying to connect them together. This only seems to occur while working w...
by DavidSwygart
Tue Dec 18, 2018 3:13 pm
Forum: Anatomically detailed models
Topic: Placing a point process at a known 3D location
Replies: 3
Views: 1054

Re: Placing a point process at a known 3D location

Thanks! I was thinking of doing something like this, but I just thought I would check because I often use way too many for loops to solve simple problems. I did implement the strategy you outlined and it worked great.
by DavidSwygart
Tue Dec 18, 2018 3:10 pm
Forum: The GUI
Topic: Broken Voltage Grapher
Replies: 3
Views: 1434

Re: Broken Voltage Grapher

Just an update for anyone reading this. I was creating a cell using custom code that read data from an SWC file. I switched to importing the SWC information using the import3D tool and everything is working now.
by DavidSwygart
Tue Dec 11, 2018 11:45 am
Forum: Anatomically detailed models
Topic: Placing a point process at a known 3D location
Replies: 3
Views: 1054

Placing a point process at a known 3D location

Using import3D I have created an anatomically detailed model of a cell from an SWC file. I now want to add synapses to this model. I know the 3D location of each synapse and have determined the 3D point from the SWC file that each synapse is closest to. Now, what is the best way to add these synapse...
by DavidSwygart
Wed Dec 05, 2018 12:33 pm
Forum: The GUI
Topic: Broken Voltage Grapher
Replies: 3
Views: 1434

Re: Broken Voltage Grapher

Hello, thanks for your quick response. I have sent the code that I have been having trouble with. I now notice that when I reduce nseg to a lower value, the grapher doesn't work even without specifying Ra. So, I am very confused as to what is going on.
by DavidSwygart
Wed Dec 05, 2018 1:17 am
Forum: The GUI
Topic: Broken Voltage Grapher
Replies: 3
Views: 1434

Broken Voltage Grapher

Hello, I am new to NEURON and am having problems using the GUI to plot voltage. I have created a script (SWC_read.hoc) to load SWC morphology data and add synapses at specific locations and also record voltage from output synapse locations. As I go along, I have been using the GUI to run the simulat...