Search found 12 matches

by santana_loren9
Fri Dec 15, 2017 7:39 pm
Forum: The GUI
Topic: spike frequency vs current graph
Replies: 16
Views: 17392

Re: spike frequency vs current graph

Hi Ted,

Thanks for the clarification. I wasn't exactly sure what was meant by accumulating ion. I will get back to you as soon as I can. I'm in the midst of finals so it's a bit hectic. Thank you for all your help and expertise.
by santana_loren9
Thu Dec 07, 2017 9:40 pm
Forum: The GUI
Topic: spike frequency vs current graph
Replies: 16
Views: 17392

Re: spike frequency vs current graph

Hi Ted, Thanks for the question. To be honest, I don't know the answer as to what the authors wanted. I am trying to replicate a paper and this was the model that they put up. The f-I curve is something I'm checking for something else, but I intended to use the base model as given. I normally use Ma...
by santana_loren9
Tue Dec 05, 2017 6:21 pm
Forum: The GUI
Topic: spike frequency vs current graph
Replies: 16
Views: 17392

Re: spike frequency vs current graph

First off, I am so sorry for asking so many questions. I do try to do some research on the forum before asking. I unfortunately chose to learn NEURON in the last few weeks of the semester. I promise I'll get better! With that said, I am having issues figuring out the spike frequency. I am trying to ...
by santana_loren9
Tue Dec 05, 2017 5:10 pm
Forum: Adding new mechanisms and functions to NEURON
Topic: "My mechanisms don't load!"
Replies: 21
Views: 30487

Re: "My mechanisms don't load!"

I'm sorry, I do have one more question. If you add new things to the folder where you have hoc and mod files or if you make a change to a hoc file in the folder, do you have to drag the whole folder again to mknrndll?
by santana_loren9
Tue Dec 05, 2017 2:52 pm
Forum: Adding new mechanisms and functions to NEURON
Topic: "My mechanisms don't load!"
Replies: 21
Views: 30487

Re: "My mechanisms don't load!"

Thank you for that explanation.
Yes, I do have many mod files. I was trying to start with two to see if I could identify the problem.
Thanks Ted.
by santana_loren9
Mon Dec 04, 2017 11:43 pm
Forum: Adding new mechanisms and functions to NEURON
Topic: "My mechanisms don't load!"
Replies: 21
Views: 30487

Re: "My mechanisms don't load!"

Also, based on your last comment, I dragged the whole folder instead of each file individually and now I'm not getting the error message. Is that the error? Should I be okay from now on? I got the following message when I run a hoc file: -e NEURON -- VERSION 7.5 master (6b4c19f) 2017-09-25 Duke, Yal...
by santana_loren9
Mon Dec 04, 2017 11:03 pm
Forum: Adding new mechanisms and functions to NEURON
Topic: "My mechanisms don't load!"
Replies: 21
Views: 30487

Re: "My mechanisms don't load!"

Hi Ted, Thank you for getting back to me. When I said I drag the mod files to mknrndll, I mean that I dragged each individual mod file and new files kept being added to the x86_64 folder. The x86_64 folder is in the same folder that contains my hoc and mod files. Also, I'll add that my hoc and mod f...
by santana_loren9
Mon Dec 04, 2017 8:11 pm
Forum: Adding new mechanisms and functions to NEURON
Topic: "My mechanisms don't load!"
Replies: 21
Views: 30487

Re: "My mechanisms don't load!"

Dear all, I've read a couple of the forums regarding this topic, yet I cannot fix my code. I am receiving the error /Applications/NEURON-7.5/nrn/x86_64/bin/nrniv: syntax error in snc_compensation.hoc near line 12 insert leak_dop ^ as others have mentioned. I have a hoc file in the same folder as the...
by santana_loren9
Mon Dec 04, 2017 7:08 pm
Forum: Getting started
Topic: No graphs plotting
Replies: 4
Views: 11816

Re: No graphs plotting

Thank you. Yes, that problem was solved. Sorry, didn't see this post.
by santana_loren9
Thu Oct 26, 2017 3:56 pm
Forum: Getting started
Topic: No graphs plotting
Replies: 4
Views: 11816

Re: No graphs plotting

Hi Ted,

Thanks for the reply. I did as you asked and graphs were produced when I clicked init&run.
I feel so foolish now. After doing that, I realized that clicking on the graph button isn't sufficient. I have to first click on tools > runcontrol >init&run.

Thank you.
by santana_loren9
Wed Oct 25, 2017 8:21 am
Forum: Getting started
Topic: No graphs plotting
Replies: 4
Views: 11816

No graphs plotting

I am just starting with NEURON. I decided to work through the following tutorial: http://web.mit.edu/neuron_v7.4/nrntuthtml/tutorial/tutA.html I did everything through the end, however, when I click on graphs and voltage, no graph shows up. Same thing when I click on the other links under graph. I k...