Search found 5 matches

by xzc
Mon Jun 12, 2017 7:28 am
Forum: NEURON + Python
Topic: Python NEURON
Replies: 15
Views: 16979

Re: Python NEURON

I have tried the new version,after setting the environment variable, it works with python3.5 except that importing rxd. Thank you very much! Here is another attempt at getting a single installer that works with python 2.7, 3.5, and 3.6. The test python -c 'import neuron ; neuron.test()' works with t...
by xzc
Tue Jun 06, 2017 5:11 am
Forum: NEURON + Python
Topic: Python NEURON
Replies: 15
Views: 16979

Re: Python NEURON

The error "Path not updated,original length 1036>1024" is because of that I don't have enough space to set the dos path. And I ran the new setup.exe installer,but when I lauched python and executed "import neuron", I met the error: Python 3.5.2 |Anaconda 4.1.1 (64-bit)| (default, Jul 5 2016, 11:41:1...
by xzc
Thu Jun 01, 2017 10:18 pm
Forum: NEURON + Python
Topic: Python NEURON
Replies: 15
Views: 16979

Re: Python NEURON

I have tried the new version, it does not work for python3.5. And I met the problem as following "Path not updated,original length 1036>1024" http://www.neuron.yale.edu/ftp/neuron/versions/alpha/nrn-7.5.master-1605.x86_64-w64-mingw32-setup.exe is my first attempt at an installer that will work with ...
by xzc
Mon May 22, 2017 9:52 pm
Forum: NEURON + Python
Topic: Python NEURON
Replies: 15
Views: 16979

Re: Python NEURON

Thans for your reply!And I am looking forward to your good news. The nrn-7.5.master-1570 installer for windows is also restricted to Python2. I am now able to build a generic version of the nrn installer on linux for Python2 and 3.x but my virtualbox win7 guest where I prepare windows installers was...
by xzc
Sun May 21, 2017 10:07 pm
Forum: NEURON + Python
Topic: Python NEURON
Replies: 15
Views: 16979

Re: Python NEURON

I also used Python 3.5, Anaconda and win 10, I have tried http://www.neuron.yale.edu/ftp/neuron/versions/alpha/nrn-7.5.master-1570.x86_64-w64-mingw32-setup.exe, but I still can not use Python with NEURON. So I have a question about whether there is a new version suitable for Python3? At present the ...